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Legal Information and Disclaimers

AMBIQ MICRO INTENDS FOR THE CONTENT CONTAINED IN THE DOCUMENT TO BE ACCURATE AND RELIABLE. THIS
CONTENT MAY, HOWEVER, CONTAIN TECHNICAL INACCURACIES, TYPOGRAPHICAL ERRORS OR OTHER MISTAKES.
AMBIQ MICRO MAY MAKE CORRECTIONS OR OTHER CHANGES TO THIS CONTENT AT ANY TIME. AMBIQ MICRO
AND ITS SUPPLIERS RESERVE THE RIGHT TO MAKE CORRECTIONS, MODIFICATIONS, ENHANCEMENTS,
IMPROVEMENTS AND OTHER CHANGES TO ITS PRODUCTS, PROGRAMS AND SERVICES AT ANY TIME OR TO
DISCONTINUE ANY PRODUCTS, PROGRAMS, OR SERVICES WITHOUT NOTICE.

THE CONTENT IN THIS DOCUMENT IS PROVIDED "AS IS". AMBIQ MICRO AND ITS RESPECTIVE SUPPLIERS MAKE NO
REPRESENTATIONS ABOUT THE SUITABILITY OF THIS CONTENT FOR ANY PURPOSE AND DISCLAIM ALL
WARRANTIES AND CONDITIONS WITH REGARD TO THIS CONTENT, INCLUDING BUT NOT LIMITED TO, ALL IMPLIED
WARRANTIES AND CONDITIONS OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NON-
INFRINGEMENT OF ANY THIRD PARTY INTELLECTUAL PROPERTY RIGHT.

AMBIQ MICRO DOES NOT WARRANT OR REPRESENT THAT ANY LICENSE, EITHER EXPRESS OR IMPLIED, IS GRANTED
UNDER ANY PATENT RIGHT, COPYRIGHT, MASK WORK RIGHT, OR OTHER INTELLECTUAL PROPERTY RIGHT OF
AMBIQ MICRO COVERING OR RELATING TO THIS CONTENT OR ANY COMBINATION, MACHINE, OR PROCESS TO
WHICH THIS CONTENT RELATE OR WITH WHICH THIS CONTENT MAY BE USED.

USE OF THE INFORMATION IN THIS DOCUMENT MAY REQUIRE A LICENSE FROM A THIRD PARTY UNDER THE
PATENTS OR OTHER INTELLECTUAL PROPERTY OF THAT THIRD PARTY, OR A LICENSE FROM AMBIQ MICRO UNDER
THE PATENTS OR OTHER INTELLECTUAL PROPERTY OF AMBIQ MICRO.

INFORMATION IN THIS DOCUMENT IS PROVIDED SOLELY TO ENABLE SYSTEM AND SOFTWARE IMPLEMENTERS TO
USE AMBIQ MICRO PRODUCTS. THERE ARE NO EXPRESS OR IMPLIED COPYRIGHT LICENSES GRANTED HEREUNDER
TO DESIGN OR FABRICATE ANY INTEGRATED CIRCUITS OR INTEGRATED CIRCUITS BASED ON THE INFORMATION IN
THIS DOCUMENT. AMBIQ MICRO RESERVES THE RIGHT TO MAKE CHANGES WITHOUT FURTHER NOTICE TO ANY
PRODUCTS HEREIN. AMBIQ MICRO MAKES NO WARRANTY, REPRESENTATION OR GUARANTEE REGARDING THE
SUITABILITY OF ITS PRODUCTS FOR ANY PARTICULAR PURPOSE, NOR DOES AMBIQ MICRO ASSUME ANY LIABILITY
ARISING OUT OF THE APPLICATION OR USE OF ANY PRODUCT OR CIRCUIT, AND SPECIFICALLY DISCLAIMS ANY
AND ALL LIABILITY, INCLUDING WITHOUT LIMITATION CONSEQUENTIAL OR INCIDENTAL DAMAGES. “TYPICAL”
PARAMETERS WHICH MAY BE PROVIDED IN AMBIQ MICRO DATA SHEETS AND/OR SPECIFICATIONS CAN AND DO
VARY IN DIFFERENT APPLICATIONS AND ACTUAL PERFORMANCE MAY VARY OVER TIME. ALL OPERATING
PARAMETERS, INCLUDING “TYPICALS” MUST BE VALIDATED FOR EACH CUSTOMER APPLICATION BY CUSTOMER’S
TECHNICAL EXPERTS. AMBIQ MICRO DOES NOT CONVEY ANY LICENSE UNDER NEITHER ITS PATENT RIGHTS NOR
THE RIGHTS OF OTHERS. AMBIQ MICRO PRODUCTS ARE NOT DESIGNED, INTENDED, OR AUTHORIZED FOR USE AS
COMPONENTS IN SYSTEMS INTENDED FOR SURGICAL IMPLANT INTO THE BODY, OR OTHER APPLICATIONS
INTENDED TO SUPPORT OR SUSTAIN LIFE, OR FOR ANY OTHER APPLICATION IN WHICH THE FAILURE OF THE
AMBIQ MICRO PRODUCT COULD CREATE A SITUATION WHERE PERSONAL INJURY OR DEATH MAY OCCUR.
SHOULD BUYER PURCHASE OR USE AMBIQ MICRO PRODUCTS FOR ANY SUCH UNINTENDED OR UNAUTHORIZED
APPLICATION, BUYER SHALL INDEMNIFY AND HOLD AMBIQ MICRO AND ITS OFFICERS, EMPLOYEES, SUBSIDIARIES,
AFFILIATES, AND DISTRIBUTORS HARMLESS AGAINST ALL CLAIMS, COSTS, DAMAGES, AND EXPENSES, AND
REASONABLE ATTORNEY FEES ARISING OUT OF, DIRECTLY OR INDIRECTLY, ANY CLAIM OF PERSONAL INJURY OR
DEATH ASSOCIATED WITH SUCH UNINTENDED OR UNAUTHORIZED USE, EVEN IF SUCH CLAIM ALLEGES THAT
AMBIQ MICRO WAS NEGLIGENT REGARDING THE DESIGN OR MANUFACTURE OF THE PART.
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Introduction

The open source Eclipse IDE is not formally supported in AmbiqSuite SDK and only limited tests
are performed. AmbiqSuite does support GCC makefiles and all examples compiled and tested
in the environment. This application note provides a step-by-step procedure to setup Eclipse
development and debugging environment on machines running Windows operating systems.
In this document, Windows 10 64-bit is used an example. It outlines the open source tools that
need to be downloaded, but the user should keep in mind that these tools change quite rap-
idly and some research may be required to get the latest versions.
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Installation

Use the following procedure to install:

1. Java Runtime Environment (JRE) or Java Development Kit (JDK)
= JRE s sufficient for our usage.
= https://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html

= Make sure JRE is in Windows environment variable Path.

2. GNU MCU Eclipse Arm Embedded GCC
=  Download from https://github.com/gnu-mcu-eclipse/arm-none-eabi-gcc/releases/
= Extractand place it to a proper location and add this path to Windows environment vari-
able Path.

3. GNU MCU Eclipse Windows Build Tools
= Download from https://github.com/gnu-mcu-eclipse/windows-build-tools/releases
= Extract and place it to a proper location.

For example:

V] = | GNU MCU Eclipse

Home Share View
<« v C\GNU MCU Edlipse

Name

## Quick access
ARM Embedded GCC
@@ OneDrive Build Tools

<& This PC

¥ Network
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Eclipse Environment Setup Application Note Installation

4. GNU MCU Eclipse IDE for C/C++ Developers
= Download from https://github.com/gnu-mcu-eclipse/org.eclipse.epp.packages/
releases. Make sure the version matches the installed JRE, both 32-bit version or 64-bit.

= Extract and place it to a proper location.

5. J-Link Software and Documentation pack for Windows
= Download from https://www.segger.com/downloads/jlink/#J-LinkSoftwareAndDocu-
mentationPack and install it.
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Eclipse Setup

Use the following procedure to setup Eclipse:

1.
2.

Launch Eclipse and you will be asked to setup a workspace which can be anywhere.

In Eclipse, navigate to Window > Preferences. In the left panel, unfold MCU and configure
Global Arm Toolchains Paths, Global Build Tools Path and Global SEGGER J-Link Path.

& Preferences

type filter text
¥ MCU

Global ARM Toelchains Paths
Global Build Tools Path
Global Jumper Path
Global OpenOCD Path
Global pyOCD Path
Global QEMU Path
Global RISC-V Toolchains Paths
Global SEGGER J-Link Path
Workspace ARM Toolchains Paths
Workspace Build Tools Path
Workspace Jumper Path
Workspace OpenOCD Path
Workspace pyOCD Path
Workspace QEMU Path
Workspace RISC-V Toolchains Paths
Workspace SEGGER J-Link Path

Mylyn

Qomph

Remote Development

RPM

Run/Debug

Toam

Global ARM Toolchains Paths

Configure the locations where various GNU ARM toolchains are installed. The values are stored within Eclipse. Unless redefined more
specifically, they are used for all projects in all workspaces.

Default toclchain: GNU MCU Edipse ARM Embedded GCC ~
Toolchain name:  GNU MCU Eclipse ARM Embedded GCC
loolchain folder:  CAGNU MCU tclipse\ARM Embedded GCC\/.3,1-1,1-20180724-0637\bin Browse...

Restore Defaults Apply

Apply and Close Cancel
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Eclipse Environment Setup Application Note Eclipse Setup
& Preferences ] X

type filter text
v MCU
Global ARM Toolchains Paths
Global Build Tools Path
Global Jumper Path
Global OpenOCD Path
Global pyOCD Path
Global QEMU Path
Global RISC-V Toolchains Paths
Global SEGGER J-Link Path
Workspace ARM Toolchains Paths
Workspace Build Tools Path
Workspace Jumper Path
Workspace OpenOCD Path
Workspace pyOCD Path
Workspace QEMU Path
Workspace RISC-V Toolchains Paths
Workspace SEGGER J-Link Path
> Mylyn
Qomph
> Remote Development
RPM
Run/Debug

% Team

Global Build Tools Path

all workspaces.

Build tools folder: | CAGNU MCU Edlipse\Build Tools\2.11-20180428-1604\bin

The locations where various GNU MCU Eclipse build tools are installed. Unless defined more specifically, they are used for all projects in

Browse... xPack...

Restore Defaults Apply

@daeh @

& Preferences

type filter text
v MCU

Global ARM Toolchains Paths
Global Build Tools Path
Global Jumper Path
Global OpenOCD Path
Global pyOCD Path
Global QEMU Path
Global RISC-V Toolchains Paths
Global SEGGER J-Link Path
Workspace ARM Toolchains Paths
Workspace Build Tools Path
Workspace Jumper Path
Workspace OpenOCD Path
Workspace pyOCD Path
Workspace QEMU Path
Workspace RISC-V Toolchains Paths
Workspace SEGGER J-Link Path

Mylyn

Oomph

Remote Development

RPM

Run/Debug

> Team

® s ©

Global SEGGER J-Link Path

Apply and Close Cancel

Configure the location where SEGGER J-Link is installed. The values are stored within Eclipse. Unless redefined more specifically, they are

used for all projects in all workspaces.

After installing SEGGER updates, restart Eclipse for the defaults to be re-evaluated and use the Restore Defaults button to configure the

new location.

Executable: ‘ JLinkGDBServerCL.exe

Folder: l C:/Program Files (x86)/SEGGER/JLink_V640/

Browse... xPack...

Restore Defaults Apply

Apply and Close Cancel
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Project Import and

Compilation

Use the following procedure to import and compile projects:

e Import

Select

Creates a new Makefile project in a directory containing existing code

Select an import wizard:
type filter text
& General
v &C/IC++
&1 C/C++ Executable
& C/C++ Project Settings
Ed Existing code as Autotools project
k] Existing Code as Makefile Project
& Git
& Install
& Oomph
& RPM
& Run/Debug
& Tasks
& Team
& TextMate
& Tracing
= XML

Cancel

1. In Eclipse, navigate to File >Import. Select C/C++>Existing Code as Makefile Project. Click
Next. For projects which are to be imported for the first time use this option. For those proj-
ects which have previously been imported to Eclipse (check if the files, .project and .cproj-
ect, and the folder .settings exist in <project>/gcc,) select General >Existing Projects
into Workspace.

\,
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Eclipse Environment Setup Application Note Project Import and Compilation

2. Select the targeting project. Take the project clkout of R2.0 for Apollo3 as an example.

= Change the project name (optional).
= Select ARM Cross GCC in Toolchain for Indexer Settings.

& New Project O X
Import Existing Code

Create a new Makefile project from existing code in that same directory

Project Name

clkout_eclipse_gcc ‘

Existing Code Location

pace\ambiqsuite-rel1.2.12\board s\apoIIoZ_evb\exampIes\cIkout\gcd ‘ Browse...

Languages

C C++

Toolchain for Indexer Settings

<none>

ARM Cross GCC
Cross GCC

Cygwin GCC
GNU Autotools Toolchain
RISC-V Cross GCC

Show only available toolchains that support this platform

@ < Back Next > Cancel

3. After the project is imported, the project explorer shows the project like the following
screenshot.

%5 Project Explorer BS| e =0

v @5 > clkout_eclipse_gcc [ambigsuite-rel1.2.12 master]
& bin
le) > startup_gcc.c
5 > clkout.Id
@ > Makefile
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Eclipse Environment Setup Application Note Project Import and Compilation

4. Right click on the project and go to Properties > C/C++ Builds > Build Variables. Add two
variables as highlighted in below. Click Apply and Close.

[=] Properties for clout_eclipse_gcc O X
type filter text Build Variables T
Resource
Builders .
v C/C++ Build Configuration: Default [Active ] ~ | Manage Configurations...

Build Variables
Environment

Logging Name Type Value Add...
Settings cross_make String make Edit.”
Tool Chain Editor cross_prefix String arm-none-eabi-
C/C++ General LG
Git
Linux Tools Path
MCU
Project Natures
Project References
Run/Debug Settings
EZ:: ?:g:sﬁory (L] Show system variables
Validation
WikiText Build Variables are IDE only variables, which can be used for string substitution when defining external builder configuration,
such as environment variable value or command line parameter in form of ${VAR], internal builder may use them directly.
Restore Defaults Apply

5. Right click on the project and select Clean Project.

olems lasks B Console ¥ operties

CDT Build Console [clout_eclipse_ged]

17:14:13 **** Clean-only build of configuration Default for project clout_eclipse_gcc ****
make clean
Cleaning...

17:14:13 Build Finished. © errors, © warnings. (took 317ms)

6. Right click on the project and select Build Project.

oblems asks B Console 2 [ Properties

CDT Build Console [clout_eclipse_gcd]
17:22:10 **** Build of configuration Default for project clout_eclipse_gcc *¥**
make all

Compiling gecc ../src/clkout.c

Compiling gecc ../../../../../utils/am_util_delay.c
Compiling gcc ../../../../../utils/am_util_faultisr.c
Compiling gcc ../../../../../utils/am_util_stdio.c
Compiling gcc ../../../../../devices/am_devices_led.c

Compiling gcc startup_gcc.c
Linking gcc bin/clkout.axf
Copying gcc bin/clkout.bin...

17:22:11 Build Finished. © errors, © warnings. (took 1s.376ms)
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Project Debugging

Use the following procedure to debug a project:

1. Navigate to Run > Debug Configurations.

& Debug Configurations (] X
Create, manage, and run configurations E\.
& § B~

Configure launch settings from this dialog:
type filter text - Press the ‘New Configuration’ button to create a configuration of the selected type.
€ C/C++ Application

¥ - Press the 'New Prototype' button to create a launch configuration prototype of the selected type.
[€1 C/C++ Attach to Application

- Press the 'Export’ button to export the selected configurations.

€] C/C++ Container Launcher

[l C/C++ Postmortem Debugger = - Press the ‘Duplicate’ button to copy the selected configuration.

[E1C/C++ Remote Application % - Press the 'Delete’ button to remove the selected configuration.
i C/C++ Unit

Ci

. it - Press the 'Filter' button to configure filtering options.
GDB Hardware Debugging

GDB Jumper Debugging - Edit or view an existing configuration by selecting it.

GDB OpenOCD Debugging It/ - Select launch configuration(s) and then select "Link Prototype’ menu item to link a prototype.
GDB PyOCD Debugging

]

lu - Select launch configuration(s) and then select 'Unlink Prototype’ menu item to unlink a prototype.

€1 GDB QEMU Debugging

=1 GDB SEGGER J-Link Debugging I8l - Select launch configuration(s) and then select 'Reset with Prototype Values' menu item to reset with prototype values.
& Launch Group

# Launch Group (Deprecated) Configure launch perspective settings from the ‘Perspectives' preference page.

Filter matched 14 of 14 items

& Debug Close

2. Right click on GDB SEGGER J-Link Debugging and select New Configuration.
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Eclipse Environment Setup Application Note

Project Debugging

3. In Main page, make sure Project has the name identical to the one set in project import and

C/C++ Application pointed to the corresponding .axf file.

o Debug Configurations ] X
Y —
Create, manage, and run configurations "
i HeEX B Name: | clout_eclipse_gee Default
type filter text % : :
Y Tter tex =l Main . % Debugger #® Startup & Source ™ Common = SVD Path
[E1C/C++ Application .
[E1C/C++ Attach to Applicaljon st
E C/C++ Container Launch clout_eclipse_gee Browse..
E1C/C++ Postmortem Debfigar | C/C++ Application:
[E1C/C++ Remote Applicatigin bimdkout axf
o C/C++ Unit : :
[E1GDB Hardware Debuggi Variables... Search Project... Browse..
[£1GDB Jumper Debugging Build (if required) before launching
[E1GDB OpenOCD Debugging Build Configuration: Select Automatically ¥
[E1GDB PyOCD Debugging -
1GDB QEMU Debugging b (O Disable auto build
v [£]GDB SEGGER J-Link Dabuggit (®) Use workspace settings Configure Workspace Settings...
=1 clout_eclipse_gcc Default
& Launch Group
# Launch Group (Deprecated)
< >
Filter matched 15 of 15 items bevert Apply
@ Close

14
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Eclipse Environment Setup Application Note Project Debugging

4. In Debugger page, make sure Actual executable is correctly interpreted and Device name is
added.

& Debug Configurations [} x

Create, manage, and run configurations §L

iHeEXIBH Name: | clout_eclipse_gee Default

type filter text
[ C/C++ Application
[E] C/C++ Attach to Application
E C/C++ Container Launch
[E1 C/C++ Postmortem Debfigge
[E1C/C++ Remote Applicatign Actual executable:| C:/Pragram Files (x86)/SEGGER/Nink V&40//)LinkGDEServerCLexe |
CT C/C++ Unit
[ GDB Hardware Debuggin
1 GDB Jumper Debugging

El Main[f* Debugger-"x_i* Startuplfé Source [ Common | % SVD Path|
J-Link GDB Server Setup
Start the J-Link GDB server locally [ |connect to running target

Executable path: | Hilink_path}/S{jlink_gdbserver} Browse... |Variablfs...

{to change it use the global or workspace preferences pages or the project properties page)

Device name: AMAPHTEK-KBR

[ GDB OpenOCD Debugging Eren s ® Little (_E;. i )

€1 GDB PyOCD Debugging Connection: ®uss O1Ip | [USB serial or IP name/address)

[£1GDB QEMU Debugging Interface: ®swo O ITAG

~ [ GDB SEGGER J-link Debuggit | |nitial speed: (O Auto () Adap @) Fixed | 1000 | kHz
=] clout_eclipse_gec Default
- GDB port: 2331

# Launch Group P I:

# Launch Group (Deprecated) SWO port: | 2332 [~ Verify downloads [ Initialize registers on start
Telnet port: 2333 Local host only [ ] Silent
Log file: | Browse...
Other options: | -singlerun -strict -timeout 0 -nogui

Allocate console for the GDB server Allacate console for semihosting and SWO

GDE Client Setup

Executable name: | ${cross_prefixjgdb${cross_suffix} Browse... Variables...

Actual executable: | arm-none-eabi-gdb |

Other options: | |

Commands: set mem inaccessible-by-default off

Remote Target
Hast name or IP address: localhost

Part number: 2331

[ Force thread list update on suspend

Restore defaults

< >
Filter matched 15 of 15 items

® Glose

Revert Apply
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Eclipse Environment Setup Application Note Project Debugging

5. In SVD page, add the path to the targeting board SVD file located in <SDK>/pack. Click
Apply and Debug.

& Debug Configurations [} e

Create, manage, and run configurations ﬁ\

CELACRL NS Name: | clout_eclipse_gee Default

type filter text
[E1C/C++ Application
[E]1C/C++ Attach to Application
E C/C++ Container Launcher
[E1C/C++ Postmortem Debugge
[E]C/C++ Remote Application
©F C/C++ Unit
[E1GDB Hardware Debugging
E1GDR Jumper Debugging
E1GDB OpenOCD Debugging
[€1GDR PyOCD Debugging
[E1GDB QEMU Debugging

v [E1GDB SEGGER J-Link Debuggit

=] clout_eclipse_gece Default

A Launch Group
# Launch Group (Deprecated)

=1 Main | % Debugger | ® Startup | % Source | Common 7. 5VD Path
SVD file (used by the peripheral registers viewer)
File ) :space\ambiqsui're-reh.2.‘IZ\pack\SVD\apoHoE.svc‘ Browse... |Variables...

£ e
Filter matched 15 af 15 iterms Revert Apply

© Close
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Eclipse Environment Setup Application Note

Project Debugging

6. After the debugger is launched, the program stops at the main function. Click the run icon
highlighted in the red frame below. The LEDs on EVB shall start to blink.

© cclipse_workspace_ambigsuite-rel1.2.12 - C:A\Users\LTien\Do \workspace

File Edit Source Refactor Navigate Search Project Run Window Help

dkout\src\ckout.c - Eclipse IDE

bigsuite-rel1.2.12\board: o2 Pl

4][%| =] ®Debug @ dout_edlipse_gcc Defa =K 4 “ ®v O -E - + 2% BvOorQvrocsv @ - - vrow Juick Access| || 1 | B8
# Debug = # clkoutc “» Variables * Breakpoints % Expressions ™ Modules “. Peripherals
~ [ dout_ediipse_gcc Default [GDB SEGGER J-Link Debug | 69 int32_t iRisingCount, iLEDcount; ~ =
~ & dkout.axf boel biewClkout, bOldClkout; Peripheral Address  Description A
~ 4 Thead #1 57005 (Suspended : Breakpoint) [J%ADC  0x50010... Analog Digital Converter Control
= main{) at dkout.c75 0x166 P P e []% CACHEC] 0x40018... Flash Cache Controller
8 JLinkGDBServerCL exe 74 [J% CLKGEN 0x40004... Clock Generator
& arm-none-eabi-gdb g 75 am_hal_clkgen_sysclk_select(AM_HAL_CLKGEN_SYSCLK_MAX); [ CTIMER  0x40008... Counter/Timer
& Semihosting and SWV e [J%GPI0  0x40010_. General Purpose IO
4 ki el s []%. IOMSTRC 0x50004... 12C/SPI Master
79 []% IOMSTR1 0x50005... 12C/SPI Master
se am_hal_cachectrl_enable(8am_hal_cachectrl_defaults); [(]% IOMSTR2 0x50006... 12C/SP| Master
8 []% IOMSTR3 0x50007... 12C/SP| Master
o I p— [ IOMSTR4 0x50008... 12C/SPI Master
Configure the board for low power operation e e v
>

am_bsp_low_power_init();

rface for ITM 0 output.

Initialize the printf

am_util_stdio_printf_init((am_util_stdio_print_char_t) am_bsp_itm_string_ ¥
>

@ Console
GNU MCU Edipse Packs console

2018-11-23 17:34:05
Parsing SVD file "C:\Users\LTien\Documents\workspace\ambiqsuite-rell.2.12\pack\SVvD\apollo2.svd"...

Completed in 8lms.

ME vy
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Troubleshooting

Make sure Windows Environment variable Path is configured correctly. For Windows 10,
right click on This PC and navigate to Properties > Advanced system settings > Environ-
ment Variables, and check the variable Path.

. Contact regional Ambiq Field Application Engineers if you encounter further questions.
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